Unable to access webmail
Incident Report for IT Services
Resolved
This incident has been resolved.
Posted Jul 22, 2021 - 15:41 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2021 - 17:27 BST
This incident affected: Systems (Staff Email).