Digital Storefront file upload functionality not working
Incident Report for ICT Services
Resolved
Resolved by EFi, 3rd party contractor.
Posted 9 months ago. Oct 31, 2018 - 09:27 GMT
Investigating
Some users have reported issues with uploading and previewing files.

Our contractor Ricoh UK has been notified and is investigating the issue. More details to follow.
Posted 9 months ago. Oct 22, 2018 - 15:08 BST
This incident affected: Print & Copy (Digital store front (DSF)).