Webmail unavailable
Incident Report for IT Services
Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 16:10 BST
Investigating
We are currently investigating an issue with being unable to access Webmail. Using the Outlook client on your PC/Laptop is unaffected.
Posted Jul 21, 2021 - 16:03 BST
This incident affected: Systems (Staff Email).