Degraded Performance of Webmail
Incident Report for ICT Services
Resolved
This issue has been resolved. Webmail is working normally.
Posted 9 months ago. Oct 18, 2018 - 14:21 BST
Monitoring
IT have implemented a fix regarding issues accessing Webmail and are now monitoring to ensure stability.
Updates to follow.
Posted 10 months ago. Sep 25, 2018 - 14:43 BST
Identified
IT have identified the cause of issues accessing Webmail and are working to resolve the issue.
Updates to follow.
Posted 10 months ago. Sep 25, 2018 - 14:43 BST
Investigating
IT are currently investigating issues accessing Webmail. This is currently affecting staff only.

Updates to follow.
Posted 10 months ago. Sep 25, 2018 - 08:50 BST
This incident affected: Systems (Staff Email).