Library Search running slow
Incident Report for ICT Services
Resolved
This issue is now resolved.
Posted 9 months ago. Oct 26, 2018 - 09:51 BST
Investigating
We are currently experiencing slow load times for one of our Library Search systems. General, Articles and Ebooks searches are affected.
Posted 9 months ago. Oct 25, 2018 - 16:19 BST
This incident affected: Library Services (Library Search).