Webprint Service
Incident Report for ICT Services
Resolved
This incident has been resolved for all campus' now.
Posted Feb 06, 2019 - 13:56 GMT
Investigating
IT are currently investigating issues printing using the Webprint service. This is affecting both staff and students on all sites. Updates to follow.
Posted Feb 06, 2019 - 11:24 GMT